9528: Cannot connect to the Laserfiche Directory Server.

Summary

When attempting to log in to a Windows Laserfiche client, you may receive the following error:

Cannot connect to the Laserfiche Directory Server. [9528]

Causes

There is a problem with the Laserfiche Directory Service license file.

Resolutions

  1. Run C:\Program Files\Laserfiche\Directory Server\XmlEndpointUtility.exe and ensure the principal name for the directory server (and STS if applicable) are for the Laserfiche Directory Service account user.
  2. Click Save.
  3. Stop the Laserfiche Server service and delete its license file (lf.licx) and named user database (lfsnu.db) from C:\Program Files\Laserfiche\Server.
  4. In the Laserfiche Directory Service, generate a new license file for the Laserfiche Server.
  5. Place the new lf.licx file in C:\Program Files\Laserfiche\Server.
  6. Restart the Laserfiche Server service.